Error: Cannot open database requested by the login
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Error: Cannot open database requested by the login

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Article ID: 396381

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Updated On: 05-05-2025

Products

Information Centric Analytics

Issue/Introduction

The Run Staging Procedures step (4) of the nightly RiskFabric Processing job and/or the RiskFabric Intraday Processing job fails and the following error message is logged in the SQL Server Agent history log:

LogGroupDescription=Staging procedure for SEP;ErrorDesc=Error Msg: Cannot open database "sem5" requested by the login. The login failed.

Environment

Version : 6.x

Component : Symantec Endpoint Protection Integration Pack

Cause

The account used for the SEP data source integration does not have sufficient rights to the sem5 database on the host SEPM server.

Resolution

Either grant the account privileges to query the sem5 database on the host SEPM server or change the account used for the SEP data source integration in ICA.

For assistance with obtaining query privileges for the data source integration account on the SEPM server, contact your SEP or database administrator.

To change the account used for the SEP integration in Information Centric Analytics (ICA), follow this procedure:

  1. Open the Risk Fabric console
  2. Navigate to Admin > Integration > Data Sources > Choose Data Source | Symantec Endpoint Protection
  3. Click the edit icon next to the server to modify
    The Edit Connection Settings window opens
  4. Click the Next button
  5. Modify the account and/or authentication method specified under the Symantec Endpoint Protection Credentials heading
  6. Click the Next button to proceed to the Summary page
  7. Click the Next button to proceed to the Progress and Finish page
  8. Click the Finish button to close the Edit Connection Settings window