Zowe explorer - HTTP(S) error status "503" received
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Zowe explorer - HTTP(S) error status "503" received

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Article ID: 396284

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Updated On:

Products

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Issue/Introduction

A few of users are getting "HTTP(S) error status "503" received." when trying to use Zowe explorer.
Everything works fine for others using the same setup/same team configuration file. 

After a full reinstall of VSCode, a new settings.json and refreshed the zowe.config files with defaults, user still gets the 503.


Output
----------

mDetails: {

      msg: 'Rest API failure with HTTP(S) status 503',

      causeErrors: '<HTML><HEAD>\n' +

        '<TITLE>Network Error</TITLE>\n' +

        '</HEAD>\n' +

...
    source: 'http',

      errorCode: 503,

      protocol: 'https',

      port: 443,

      host: 'XXX.XXX.XXX',

      basePath: '',

      httpStatus: 503,

      errno: undefined,

      syscall: undefined,

      payload: undefined,

      headers: [ { 'X-CSRF-ZOSMF-HEADER': true } ],

      resource: '/zosmf/info',

      request: 'GET',

      additionalDetails: 'Received HTTP(S) error 503 = Service Unavailable.\n' +

Environment

ZOWE v3.1

Vscode ZOWE explorer

Cause

All HTTP 5xx errors mean that the error occurred on the server. Since that is a customer controlled network and set of z/OS services, there is typically little one can do in the Zowe client apps to affect the behavior.

One way to debug this issue is to issue ZOSMF rest API calls (If curl is available on user's system). 

curl -k -u YourUser:YourPassword -H "Accept: application/json" -H "X-CSRF-ZOSMF-HEADER: true" "https://YourHost:YourZosmfPort/zosmf/restfiles/ds?dslevel=SYS1.PARMLIB*"

Successful output of this command could look something like this:

{"items":[
  {"dsname":"SYS1.PARMLIB"},
  {"dsname":"SYS1.PARMLIB.ARCHIVE"},
  {"dsname":"SYS1.PARMLIB.BACKOUT"},
  {"dsname":"SYS1.PARMLIB.NEW"},
],"returnedRows":4,"JSONversion":1}

If the curl command to zosmf fails, it indicates that the problem is not with the Zowe clients. Customer should then focus troubleshooting on their own network issues, proxy issues, or server permissions.

Resolution

Check the proxy setting if the proxy server is in place, for example - check http_proxy from user's windows environment variables. 

Adjust the firewall policy (if there is any) so that connection to ZOSMF server is not blocked by firewall.