"Service time-out" errors are observed on the Avi UI in version 31.1.1
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"Service time-out" errors are observed on the Avi UI in version 31.1.1

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Article ID: 396274

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

In Avi version 31.1.1, users may experience 'Service time-out' errors when attempting to load Application Logs or Events within the Avi user interface.

Cause

This issue occurs in version 31.1.1 because the system's request handlers for logs and events API calls become exhausted. When no handlers are available to process new requests from the UI, the operation times out.

This issue can be identified if the following log lines are seen in the "/var/log/upstart/aviportal.log" file on the controller leader node:
Tue Mar 18 12:58:03 2025 - *** uWSGI listen queue of socket "127.0.0.1:6002" (fd: 3) full !!! (100/100) ***
Tue Mar 18 12:58:04 2025 - *** uWSGI listen queue of socket "127.0.0.1:6002" (fd: 3) full !!! (100/100) ***
Tue Mar 18 12:58:05 2025 - *** uWSGI listen queue of socket "127.0.0.1:6002" (fd: 3) full !!! (100/100) ***

 

Resolution

This issue is resolved in Avi version 31.1.2 and newer. Once released, please upgrade to the fixed version.

Workaround: You can temporarily restore service by performing a warm reboot of the Avi Controller cluster. This action clears the exhausted request handlers.

Warm Reboot Procedure:

  1. Log in to the Avi Controller shell via SSH.

  2. Execute the following commands in sequence:

    > terminal unhide
    > reboot warm
    > yes

     

Note: Please contact Broadcom Support for guidance with the controller warm reboot on a production controller cluster.