When Upgrading vSphere Replication receive "Operation not permitted: The connection was closed by the remote end during handshake" in VAMI and "Unknown error 235" in drconfig log
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When Upgrading vSphere Replication receive "Operation not permitted: The connection was closed by the remote end during handshake" in VAMI and "Unknown error 235" in drconfig log

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Article ID: 396195

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Updated On:

Products

VMware vSphere ESXi 8.0 VMware vCenter Server 8.0

Issue/Introduction

  • When upgrading vSphere Replication through VAMI, customer sees "Operation not permitted: The connection was closed by the remote end during handshake"

  • Looking in the ./vmware/support/logs/dr/drconfig.log log file, you see "Unknown error 235" and references to an incorrect rpm file.

--> Downloading:
--> Found 1 problems
--> eventlog is obsoleted by (installed) syslog-ng-4.3.1-6.ph4.x86_64

--> Error(1515) : rpm check reported errors
-->
2025-04-24T11:17:10.568-04:00 verbose drconfig[02181] [SRM@6876 sub=Installing packages opID=daa18311-5628-4e62-b19c-09e42cfc2d97-installUpdate:1b2b] Command "/usr/bin/bash -x /var/tmp/upgrade/9.0.2.16590/install.sh" exit code: 235
2025-04-24T11:17:10.568-04:00 info drconfig[02181] [SRM@6876 sub=InstallUpdateOp opID=daa18311-5628-4e62-b19c-09e42cfc2d97-installUpdate:1b2b] Exiting Start
2025-04-24T11:17:10.568-04:00 error drconfig[02181] [SRM@6876 sub=InstallUpdateOp opID=daa18311-5628-4e62-b19c-09e42cfc2d97-installUpdate:1b2b] Failed to install update: 'N7Vmacore15SystemExceptionE Unknown error 235 (235)

  • Looking in the /var/tmp/upgrade folder, you can see an old upgrade folder from a previous upgrade

Environment

vSphere Replication 9.0

Site Recovery Manager 9.0

Cause

This issue is caused by an old rpm causing a conflict with the new upgrade, in this case the syslog-ng-4.3.1-6.ph4.x86_64 file. The old upgrade config needs to be cleaned up before proceeding with the next upgrade.

Resolution

If a snapshot was taken prior to the upgrade attempt, revert the appliance to that snapshot. Then follow the below steps. If no shapshot was taken, please reach out to Broadcom support for assistance to ensure cleanup is done safely.

  1. Take a snapshot of the appliance before proceeding.
  2. Run the command "cd /var/tmp/upgrade".
  3. Run "ls -lah" to check for any folders inside of upgrade, along with their last touch date.
  4. If there is an old folder present, run the command "re -r <FolderName>" to delete the folder. In this case the command would be "rm -r 9.0.2.16590" per the previous screenshot.
  5. Run the command "rpm -e <ConflictingRpmName>" to delete the conflicting rpm called out in the drconfig log. Using the drconfig log shown above, the command would be "rpm -e syslog-ng-4.3.1-6.ph4.x86_64".
  6. Proceed with the upgrade.
  7. Once the upgrade is complete, confirm everything is functioning, and delete any snapshots created.