RSP Probe is not showing profiles in IM configuration
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RSP Probe is not showing profiles in IM configuration

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Article ID: 396144

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

All profiles have gone missing from the IM configuration.  The profiles used to appear here.  They are seen when accessing the rsp probe configuration via Admin Console.

Environment

  • UIM Infrastructure Manager 23.4.0+
  • rsp probe 5.59+

Cause

The <folders> key is missing from the configuration.  This key is only used by the IM config GUI.

OR

If the profiles are created in AC, these keys will not be created in the folders section and will be missing.

Resolution

This issue can be resolved by one of two actions:

If the 'folders' key was removed as part of a corruption and it exists in a backup of the rsp.cfg file, restore it to the rsp folder.  Then restart the probe.

OR

If the profiles were created in AC, you can create the key entries in the folders section as described below:

  • Identify the names of each of the configured profiles
    • These name can be found in the 'profiles' section of the config (example highlighted in yellow below):
      <profiles>
         <SampleServer1.domain.local>
       .....
         </SampleServer1.domain.local>
         <SampleServer2.domain.local>
       .....
         </SampleServer2.domain.local>
      </profiles>
  • Create a new entry in the config file containing these profiles:
    <folders>
       <My Remote Servers>
          0 = SampleServer1.domain.local
          1 = SampleServer2.domain.local
       </My Remote Servers>
    </folders>
  • You can also do this in Raw Configure.
  • The result in Raw Configure should look like this:
  • Deactivate/Activate the probe and the folder tree should be recreated.