[VMC on AWS] vCenter UI is not accessible via public internet after advertising 0.0.0.0/0 route
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[VMC on AWS] vCenter UI is not accessible via public internet after advertising 0.0.0.0/0 route

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Article ID: 396070

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

After advertising the default route (0.0.0.0/0) from VPC / Direct Connect / on-prem network, public access to vCenter UI is lost.

Environment

VMware Cloud on AWS

Cause

  • If the default route (0.0.0.0/0) is advertised, all the default outgoing traffic from the SDDC will take the respective private path (Eg. VMWare Transit Gateway [vTGW], Direct Connect).
  • When you try to access vCenter UI (whose DNS Resolution setting is Public IP), the incoming traffic would come in via Internet Gateway (IGW) but the outgoing traffic would take the private path (Eg. Direct Connect Gateway) which results in asymmetric routing causing the traffic to get dropped. 
  • This is an expected behavior as asymmetric routing is not supported in VMC on AWS

Resolution

This is an architectural issue and either of the below two paths can be explored for resolution:-

  1. Remove the default route (0.0.0.0/0) that is being advertised
  2. Change the vCenter DNS Resolution setting to Private IP and connect to vCenter UI via the respective private path (Documentation: Set vCenter FQDN Resolution Address)