Missing “Owner” and “Assign To” column in Alarm console
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Missing “Owner” and “Assign To” column in Alarm console

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Article ID: 396061

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

In DX UIM 20.4 once an alarm has been accepted by a user, the “Assigned To” and “Owner” column will have the user’s ID. 
Used “Assigned To” NOT IN filter to view NOT ACCEPTED new alarms.

In DX UIM 23.4 CU3 alarm console,

1. Top right 3 dots > Edit Columns > The “Assigned To” column is missing

2. add filter(s) “+” icon > Managed Filter(s) > filter field “Owner” is missing

 

Devops team is heavily depending on the alarm view that at NOT ACCEPTED yet.

Environment

UIM 23.4.3

Cause

There were two columns ("Assigned To" and "Owner") based on same alarm field assigned_to and in a fix for an issue "Assigned To" was removed from columns. 

Resolution

In 23.4.3 env there is "Owner" field in "Edit Columns" section and "Unassigned" in Column filter (when you add "owner" column in the table):

Owner in Edit Columns:

Column Filter:

If you want to use Advanced Filter/ Manage Filter , then user needs to select Owner Is null

So recommendation is to update the existing filter to use "owner"  instead of "Assigned to"

Also " owner  is null " is as per the design and value "Unassigned" there seems not possible as its a Text Box and used for many other fields as well.