VCF operations (formerly VMware Aria Operations) sync with AD does not work and users are unable to login
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VCF operations (formerly VMware Aria Operations) sync with AD does not work and users are unable to login

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Article ID: 395968

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Operations

Issue/Introduction

  • Active Directory users are unable to login to Aria Operations. The UI throws error - 'Invalid Username or Password' even though the user is visible under Access Control -> User Accounts and the password is correct
  • The /storage/log/vcops/log/web.log show the below error message for the AD user - 
    2025-04-16T13:29:33,195+0000 ERROR [ajp-nio-127.0.0.1-8009-exec-468] com.vmware.vcops.ui.action.LoginAction.proceedLogin - [Ljava.lang.StackTraceElement;@4382dfd3
    com.vmware.vcops.auth.exception.InvalidCredentialsException: No user exists with userName: AD_USERNAME and sourceId: UUID
            at com.vmware.vcops.auth.server.util.UserAuthUtils.getUserIfValid(UserAuthUtils.java:105) ~[vcops-auth-server-1.0-SNAPSHOT.jar:?]
            at com.vmware.vcops.auth.server.authN.LdapHostAuthNStrategy.login(LdapHostAuthNStrategy.java:64) ~[vcops-auth-server-1.0-SNAPSHOT.jar:?]
  • AD Users that are not protected can sign in. 

Environment

VCF operations 9.0.x

Aria Operations 8.18.x 

Cause

The AD user trying to login is part of Protected Users group on the AD server. 

Resolution

VCF operations (formerly VMware Aria Operations) does not support login for AD users that are members of Protected Users group on the Active Directory server.