Redirect towards Identity Manager error in CA Access Gateway (SPS)
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Redirect towards Identity Manager error in CA Access Gateway (SPS)

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Article ID: 395938

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Updated On:

Products

SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction


Running CA Access Gateway (SPS), the browser receives the error:

    Request URI:   /
    Error Type:    SPS Exception
    Error Code:    WebAgentException
    Error Message: Web agent has thrown error. More details in SPS logs.

 

Cause


No FQDN used for the host defined in the proxyrules.xml.

SiteMinder protection is based on cookies, and domain names.

As such, use full FQDN in configurations including the domain names, instead of just the host names.

 

Resolution


Modify the proxyrules.xml with forward action, and ensure that all machines are referred by the FQDN:

  <nete:proxyrules xmlns:nete=http://server1.example.com debug="no">
    <nete:forward>
      https://server2.example.net$0
    </nete:forward>
</nete:proxyrules>

That will make all requests to the SPS, to be forwarded in the backend to https://server2.example.net.