vSAN disk shows as Ineligible and cannot be claimed for vSAN disk group
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vSAN disk shows as Ineligible and cannot be claimed for vSAN disk group

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Article ID: 395862

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms : 

  • When attempting to create a vSAN disk group or add a disk to an existing group, the vSAN device appears as 'Ineligible for use by vSAN' in vSphere Client > vSAN Cluster > Configure > Disk Management > Host > Ineligible and Unclaimed:

Environment

VMware vSAN 7.x

VMware vSAN 8.x

Cause

For a disk to be eligible for use in vSAN, it must not have any partitions on it. If any partitions exist on the disk, especially remnants from previous configurations, vSAN will mark the disk as ineligible for use.

Example : 

Resolution

Certain functionalities, such as vSAN or virtual flash resource, require that your ESXihost uses clean storage devices. You can erase an HHD or flash device and remove all existing data.

Make sure that the host is in the connected state.

Verify that the devices you plan to erase are not in use.

Required privilege: Host.Config.Storage

  • In the vSphere Client, navigate to the ESXi host.
  • Click the Configure tab.
  • Under Storage, click Storage Devices.
  • Select one or more devices and click the Erase Partitions icon.
  • Verify that the partition information you are erasing is not critical.
  • Click OK to confirm your change.

Refer : Erase ESXi Storage Devices

If the above steps do not work the follow the fix mentioned in KB # 374125

If the above also does not work, then clear the partitions on the device from the hardware management console (iLO, iDRAC, and so on).

Additional Information