vSAN -- After Power Outage event - All VMs became "Invalid". vCenter is down. Storage is empty.
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vSAN -- After Power Outage event - All VMs became "Invalid". vCenter is down. Storage is empty.

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Article ID: 395830

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Updated On:

Products

VMware vSAN VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

Despite everything is back online after a Power Outage/Maintenance:

VMs are showing as "invalid" in the Host Client

 

vSAN Datastore is not showing any VMs

 
Note: vCenter might be located on the affected vSAN Datastore.

 

 

Environment

vSAN 7.x
vSAN 8.x

Cause

Unicastagent list is empty on one or more vSAN Hosts as shown via:

 
 
Despite the IgnoreClusterMemberListupdates setting is set to default (= 0) as shown here:

 
A vSAN Cluster can only be functional if each Host has a Unicastagent which is not empty.
The information in the Unicastagent list enables the Host to communicate to the other vSAN Hosts in the Cluster.
If the Unicastagent list is empty the Host cannot communicate to the rest of the Cluster and therefore the vSAN Datastore cannot be accessed and VMs located on it are not working.

Resolution

1.) Follow the instructions outlined in KB 326427 to manually recreate the Unicastagent list on all Hosts where it shows as empty.
2.) Verify that the Cluster is fully formed (all Hosts are in the Cluster) by running on all Hosts via SSH/Putty session:
esxcli vsan cluster get
and checking the Sub-Cluster Member Count (= reflects the number of Hosts in the Cluster)

3.) Re-evaluate whether the reported issues described via section Issue/Introduction do still exist

 

If assistance is required, please open a Ticket with VMware by Broadcom Support.