The Lifecycle Manager and the Update tab under the ESXi host view in the VCSA HTML5 interface are displaying a blank or empty pane
search cancel

The Lifecycle Manager and the Update tab under the ESXi host view in the VCSA HTML5 interface are displaying a blank or empty pane

book

Article ID: 395813

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The Lifecycle Manager item is missing from the vSphere Client.
  • Additionally, when selecting any ESXi host within the cluster and navigating to the Updates tab, the pane appears blank with no content displayed.

Environment

  • VMware vCenter Server 8.0.x

Cause

The issue is caused by a mismatch between the VUM Client Plugin version and its registration within vCenter Server.

  • As seen in the plugin-medic.log, the VUM Client Plugin with registration version 8.0.3.24322831 was successfully downloaded and validated - 
    • /var/log/vmware/vsphere-ui/logs/plugin-medic.log entries -
      • [yyyy-mm-ddThh:mm:ss.Z] [INFO ] [com.vmware.vum.client:8.0.3.24322831] FINISHED Validating [VMware vSphere Lifecycle Manager, VMware, Inc.]
  • Upon reviewing the local plugin cache directory, it was observed that the actual version of the plugin present is 8.0.2, which differs from the registered version
    • /etc/vmware/vsphere-ui/cm-service-packages/com.vmware.cis.vsphereclient.plugin/com.vmware.vum.client-8.0.3.24322831/plugin-package.xml 

<pluginPackage id="com.vmware.vum.client" version="8.0.3" name="VMware vSphere Lifecycle Manager" type="html"
      vendor="VMware, Inc." description="Lifecycle management for the vSphere Cluster, Hosts and Virtual Machines">

  • Reviewing the vsphere_client_virgo.log during the upgrade timeframe reveals that the new 8.0.3 VUM Client Plugin was not downloaded, as a plugin with the same registration version was already present - 
    • /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log entries -
      • [yyyy-mm-ddThh:mm:ss.Z] [INFO ] rvice-extension-mngr-pool-86  com.vmware.vise.plugin.download.PluginDownloadServiceImpl         Plugin package: com.vmware.vum.client:8.0.3.24322831 has already been download on a previous iteration.

Resolution

  • Remove the local plugin cache on the vCenter Server
    • Delete the contents of the plugin cache directory by running:
      • rm -r /etc/vmware/vsphere-ui/cm-service-packages
  • Restart the vSphere UI service
    • Execute the following command to restart the service:
      • service-control --restart vsphere-ui
  • Upon restart, the VUM plugin package (ZIP) will be automatically re-downloaded and extracted.