Grid Scan marked as ABORTED_SCAN
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Grid Scan marked as ABORTED_SCAN

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Article ID: 395803

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Updated On:

Products

Data Loss Prevention Data Loss Prevention API Detection Data Loss Prevention API Detection for Developer Apps Virtual Appliance Data Loss Prevention Cloud Detection Service Data Loss Prevention Cloud Detection Service for ICAP Data Loss Prevention Cloud Detection Service for REST Data Loss Prevention Cloud Package Data Loss Prevention Cloud Prevent for Microsoft Office 365 Data Loss Prevention Cloud Service for Discovery/Connector Data Loss Prevention Cloud Service for Email Data Loss Prevention Cloud Storage Data Loss Prevention Core Package Data Loss Prevention Data Access Governance Data Loss Prevention Discover Suite Data Loss Prevention Endpoint Discover Data Loss Prevention Endpoint Prevent Data Loss Prevention Enforce Data Loss Prevention Enterprise Suite Data Loss Prevention for Mobile Data Loss Prevention Form Recognition Data Loss Prevention Network Discover Data Loss Prevention Network Monitor Data Loss Prevention Network Monitor and Prevent for Email Data Loss Prevention Network Monitor and Prevent for Email and Web Data Loss Prevention Network Monitor and Prevent for Web Data Loss Prevention Network Prevent for Email Data Loss Prevention Network Prevent for Email Virtual Appliance Data Loss Prevention Network Prevent for Web Virtual Appliance Data Loss Prevention Network Protect Data Loss Prevention Oracle Standard Edition 2 Data Loss Prevention Plus Suite Data Loss Prevention Sensitive Image Recognition

Issue/Introduction

Grid scans are automatically being marked as "aborted_scan" after running for a few hours.

ScanDetails log on the grid leader server show:
"<date and time>","INFO","","ABORTED_SCAN"," ","0","","","",""

FileReader logs on the grid leader server show:
<date and time> com.vontu.discover.DiscoverManager abortScan
INFO: DiscoverControlManager_1: aborting scan
<date and time> org.apache.activemq.broker.TransportConnector stop
INFO: Connector vm://DiscoverGridScanMessageQueueBroker stopped
<date and time> com.vontu.discover.crawler.framework.RepositoryCrawler$CrawlerThread run
WARNING: Crawler is stopped on request for target <discover scan name>

Environment

Symantec Data Loss Prevention 15.8 MP3

Cause

Database connection is reporting pool exhaustion on the Enforce Server at the same time the scan is marked as aborted.

From the Localhost.<date>.log on the Enforce Server around the time the grid scan stopped:
Level: SEVERE
Source: com.vontu.manager.spring.web.ManagerHandlerExceptionResolver
Message: Unexpected exception while processing request:
Cause:
com.vontu.util.jdbc.DatabaseRuntimeException: java.sql.SQLException: Database connection failedcom.vontu.util.jdbc.DatabaseRuntimeException: java.sql.SQLException: Database connection failed
...
Caused by: java.sql.SQLException: Database connection failed
...
Caused by: com.vontu.util.jdbc.DatabaseConnectionPoolExhaustedException: A connection could not be obtained from the pool

Resolution

1. Restart the DLP services on the Enforce Server to reset the database connections pool.
2. If the grid scan does not start automatically, restart the scan