CMS0049 error with Virtual Analyst after upgrade to 17.4 RU4
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CMS0049 error with Virtual Analyst after upgrade to 17.4 RU4

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Article ID: 395793

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Updated On: 05-19-2025

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

After the upgrade of xFlow/Service Point to 17.4 RU4, Aria/Virtual Analyst stops working, and the following error appears in the Chat:

CMS0049-Failed to process your request.

<xFlowHome>\APPS\logs\CollabMS.log shows the following error:

Failed to post the message to search micro service

Connection refused: no further information: localhost/<IPV6>:9006

 

Environment

Service Management 17.4 RU4 and later

SSL environment

Cause

Starting 17.4 RU4, when SSL is enabled in xFlow/Service Point, this action will disable the xFlow/Service Point non-SSL port numbers (ie: 9002, 9006, etc). This is a change in the design since in previous versions, like 17.4 RU3, RU2, RU1, enabling SSL did not disable the non-SSL ports.

Resolution

Update the application.conf from the collab and incident microservices conf folders to point to the correct URL of the search microservice.

1. Go to <xFlow Home folder> > APPS > Services > collabmicroservice-<version>\conf\application.conf

2. Search for search.ms.url

3. Modify the URL to the SSL URL. You can get the information from <xFlow Home folder>\APPS\Services\incidentmicroservice-17.0.479\public\conf\casm.conf.js under the "search" item.

4. Save changes

5. Go to <xFlow Home folder> > APPS > Services > incidentmicroservice-<version>\conf\application.conf

6. Search for search.ms.url

7. Modify the URL to the SSL URL. You can get the information from <xFlow Home folder>\APPS\Services\incidentmicroservice-17.0.479\public\conf\casm.conf.js under the "api" and "bui" items.

8. Save changes

9. Restart xFlow Services.

Additional Information