Admin page not showing data on one of the HA nodes in HA cluster
search cancel

Admin page not showing data on one of the HA nodes in HA cluster

book

Article ID: 395735

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

If one or more nodes have the same hostname in admin page  ->you will see status for one or more nodes showing circle constantly, never showing actual data 

Environment

Aria Operations 8.x

Cause

This can occur when there is problem with DNS or node hostname configuration. In this case it was seen when both nodes were configured with different IP but the same hostname.

As per our documentation this is unsupported configuration, see VMware Aria Operations Cluster Node Networking Requirements:

Analytics cluster nodes must not have the same hostname.

Resolution

If the cluster has previously been configured where nodes are configured with different IP but the same hostname, the best course of action is remove replica and create the new one using the steps below:

  1. Take a snapshot of all nodes before applying the steps below as per our KB - How to take a Snapshot of VMware Aria Operations
  2. Change the hostname so both nodes are not with identical hostname How to change a node hostname in Aria Operations
  3. Fix the DNS records for the nodes or temporarily adjust hosts files on both nodes /etc/hosts to contain IP,  FQDN, and short name, for all nodes in the cluster with the following example format:

    192.168.0.0 hostname.domain.com hostname 

  4. stop casa on all nodes:

    systemctl stop casa.service 

  5. Change casa.db.script on all nodes starting with the Primary node to accommodate new hostname for the second node -> find the wrong hostname and change it to the new one by editing the file in "vi"  
  6. Start casa on all nodes again (1st-Primary, 2nd-Replica, 3rd-Data Nodes):

    systemctl start casa.service 

  7. Disable HA from the UI or command line, see How to enable/disable HA when the option is not available in Aria Operations UI - How to disable/enable HA
  8. Remove data node Manually removing a node from the Aria Operations cluster
  9. Add new data node to the cluster , when successfully enable HA again