Data node is in 'Inaccessible' state in Aria Operations Admin UI.
search cancel

Data node is in 'Inaccessible' state in Aria Operations Admin UI.

book

Article ID: 395726

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Data node is in 'Inaccessible' state in Admin UI.
  • The cluster is unable to come online due to one node being in an 'Inaccessible' state.
  • No data will be gathered for objects configured with a Data node as their collector.
  • Log entries in /storage/log/vcops/log/casa/casa.log may resemble the following:
    2025-##-##T##:##:##,166+0000  INFO [ajp-nio-127.0.0.1-8011-exec-5] [Fx00003d] sysadmin.cluster.DocumentCasaClusterManager:516 - IP address for the uuid localhost is not found.
    2025-##-##T##:##:##,185+0000  WARN [ajp-nio-127.0.0.1-8011-exec-5] [Fx00003d] support.function.SystemFunction:348 - Can't resolve address for ip name <DATA_NODE_FQDN>
    2025-##-##T##:##:##,191+0000  INFO [ajp-nio-127.0.0.1-8011-exec-5] [Fx00003d] sysadmin.cluster.DocumentCasaClusterManager:516 - IP address for the uuid localhost is not found.
    2025-##-##T##:##:##,192+0000  INFO [ajp-nio-127.0.0.1-8011-exec-5] [Fx00003d] casa.suiteapi.SuiteApiInternalService:424 - Submitting GET request to the suite-api at https://localhost/suite-api/internal/casa/clusters/state entity: null

Environment

Aria Operations 8.x

Cause

This issue occurs when the IP address and Fully Qualified Domain Name (FQDN) of the node do not resolve to each other correctly. This resolution failure causes the node to enter an 'Inaccessible' state.

Resolution

  • Confirm that the IP address and FQDN of the affected node can correctly resolve each other. Ensure both forward and reverse DNS lookups are accurately configured.
  • To validate DNS resolution, use the following commands:
    • nslookup <FQDN of the node>
    • nslookup <IP address of the node>



Additional Information