Unable to cancel or Force Cleanup HCX migration with the error: "Cannot force cleanup, migration is in Unknown state"
search cancel

Unable to cancel or Force Cleanup HCX migration with the error: "Cannot force cleanup, migration is in Unknown state"

book

Article ID: 395585

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • You are attempting to cancel or force cleanup for HCX migrations, and the following error is displayed on the HCX UI: "Cannot force cleanup, migration is in Unknown state"
  • The following errors are observed in /common/logs/admin/app.log:
    <timestamps> [MobilityMigrationService_EventListener, , , TxId: ] ERROR o.a.k.c.c.i.ConsumerCoordinator- [Consumer clientId=consumer-MobilityMigrationJob-0-MobilityMigrationService-53, groupId=MobilityMigrationJob-0-MobilityMigrationService] Offset commit failed on partition MobilityMigrationJob-0 at offset #######: The server experienced an unexpected error when processing the request.
    <timestamps> [MobilityMigrationService_EventListener, , , TxId: ] ERROR c.v.v.h.m.a.EventListenerAdapter- Error Retrieving event:
    org.apache.kafka.common.KafkaException: Unexpected error in commit: The server experienced an unexpected error when processing the request.
  • In addition to the logs above in app.log, the Kafka server log (/common/logs/kafka/server.log) displays the following error:
    [<timestamps>] ERROR [ReplicaManager broker=0] Error processing append operation on partition __consumer_offsets-## (kafka.server.ReplicaManager)

Environment

HCX

Cause

This issue may occur if the Kafka "__consumer_offset topic offset" is corrupted.

Resolution

This is a condition that may occur in a VMware HCX environment.

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.