Lost connection to cloud after reconfiguring VRMS - vSphere Replication Server at vCenter ServerName: Unable to connect to Cloud. Reason: The operation is not allowed in the current state.
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Lost connection to cloud after reconfiguring VRMS - vSphere Replication Server at vCenter ServerName: Unable to connect to Cloud. Reason: The operation is not allowed in the current state.

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Article ID: 395535

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

1. Reconfiguring VRMS leads to loss of communication with the cloud 

2. Time difference between vCenter, VLSR & VRMS 


dpx-agent.log:

[2025-04-10 14:56:18.022 CDT] [dpx-agent] ERROR [vcId='NA' host='vlsr.vmware.com'] [thread='dpx-schedule-thread0'] com.vmware.atlas.agent.srm.entitlement.util.ActionRunner - Action run failed:java.lang.RuntimeException: The operation is not allowed in the current state.


hms.log: 

2025-04-10 14:56:18.015 DEBUG com.vmware.hms.vmc.VmcService [tcweb-2] (..hms.vmc.VmcService) [operationID=6f929fcf-fa01-4a0c-b834-b36b85ba864d-HMS-671,sessionID=13525727] | spec.current_ts: 2025-04-10T19:56:17.058284868         
2025-04-10 14:56:18.016 INFO  com.vmware.hms.i18n.class com.vmware.hms.response.filter.I18nActivationResponseFilter [tcweb-2] (..response.filter.I18nActivationResponseFilter) [operationID=6f929fcf-fa01-4a0c-b834-b36b85ba864d-HMS-671,sessionID=13525727] | The localized message is: The operation is not allowed in the current state.

Environment

VMware vSphere Replication 9.x
VMware Live Site Recovery 9.x

Cause

This issue arises when VRMS is located in a different vCenter than the one it is registering with. SRM Engineering is aware of this problem and is currently investigating to find a solution for this problem. This issue is also seen when there is time skew between the VLSR(SRM), VRMS and vCenter appliances. 

Resolution

Workaround

If VRMS is in a different vCenter from where it's registering, vMotion the VM to the vCenter it is registering with.

1. vMotion VRMS to the vCenter its registering with 
2. Power OFF/ON VRMS appliance 
3. Reconfigure VRMS AND VLSR appliances 
4. Reconnect site pair 
5. Reconnect VLSR to VMware Live Recovery 

These should fix the error. 
 

Additional Information