Process fails in Clarity with BPM-0526: Cannot start process. Process is not active or validated
search cancel

Process fails in Clarity with BPM-0526: Cannot start process. Process is not active or validated

book

Article ID: 395462

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Process scheduled in Clarity as Execute Process job is not running and fails with error:

ERROR 2025-04-25 07:15:06,302 [Dispatch TEST PROCESS: bg@XXXXXX(tenant=clarity)] niku.njs (clarity:admin:219494069__1998DB3F-6CF6-448F-A4CB-2F4022F607D7:TEST PROCESS) () Error executing job: 5056027
java.lang.Exception: Could not execute the process (test_process)
    at com.niku.bpm.jobs.ExecuteProcessJob.scheduledEventFired(ExecuteProcessJob.java:104)
    at com.niku.njs.BGTask.run(BGTask.java:114)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
    at java.base/java.lang.Thread.run(Thread.java:840)
Caused by: com.niku.union.utility.MessageKeyException: BPM-0526: Cannot start process. Process is not active or validated.
    at com.niku.bpm.engine.BusinessProcessImpl.startProcessByVersionId(BusinessProcessImpl.java:253)
    at com.niku.bpm.engine.BusinessProcessImpl.startProcessByVersionId(BusinessProcessImpl.java:226)
    at com.niku.bpm.engine.BusinessProcessImpl.startProcessWithDocument(BusinessProcessImpl.java:153)
    at com.niku.bpm.jobs.ExecuteProcessJob.scheduledEventFired(ExecuteProcessJob.java:78)
    ... 4 more
Caused by: java.lang.Exception
    ... 8 more

Environment

All Supported Clarity Releases

Cause

The process is not Active or is put on Hold, but remains scheduled in Clarity Jobs 

Resolution

  • Go to Administration - Processes - open the Process and make sure it's Validated and Activated, and not on Hold
  • Then run the Execute Process job again