Host profile related alert does not cleared automatically even there is no real error.
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Host profile related alert does not cleared automatically even there is no real error.

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Article ID: 395388

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Host profile alert does not cleared automatically even real issue was gone.

'Reset to Green' button in Monitor -> All Issues tab is grayed out so you cannot clear it manually.

Environment

vCenter 8.x

Cause

The issue lies with the host object directly, not with the host profile object.

Resolution

There are two options as a workaround so we can choose one of these action items below.

  • Option 1. Remove problematic host from vCenter inventory and re-add it again.

  • Option 2. Delete alert from VPX_CONFIG_ISSUE table in VCDB by following the process below.

Note:  It is advisable to perform either a file-based backup or an offline snapshot of the vCenter

1) ssh to vCenter and connect VCDB

/opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres

2) Check the event_id for removing.

select * from VPX_CONFIG_ISSUE;

Example:

VCDB=# select * from VPX_CONFIG_ISSUE;
 entity_id | event_id | cfg_issue_type
-----------+----------+----------------
     12034 |   720164 |              1
     12016 |   720165 |              1

3) We don't know which item is correct one if there are many entities so we checked it from Event table.

 Replace 'EVENT_ID' value using above result.

 Check which event is related with the issue.

select event_type,host_name from VPXV_EVENT_ALL where event_id=EVENT_ID;

Example:

VCDB=# select event_type,host_name from VPXV_EVENT_ALL where event_id=720164;
 
event_type                                                                   |     host_name
--------------------------------------------------+--------------------
 com.vmware.vc.HA.HeartbeatDatastoreNotSufficient | esxi02
 
4) Running this command with event_id.
 Replace EVENT_ID to correct value which you find it from the result of 2) and 3).
 
DELETE FROM VPX_CONFIG_ISSUE where event_id = 'EVENT_ID' ;
 
Example:
VCDB=# DELETE FROM VPX_CONFIG_ISSUE where event_id = '720164' ;
DELETE 1
 
5) Check the value removed from VPX_CONFIG_ISSUE table again.
select * from VPX_CONFIG_ISSUE;
 
6) Refresh vsphere-ui and check whether alert is gone or not.
 
7) If the alert is still exist in vsphere-ui, you need to restart vpxd service.
service-control --restart vpxd
 

Additional Information

  • You might encounter stale alerts in the vSphere Web Client, such as: “Host profile apply failed error: Error: Name ‘c’ is not defined.”
  • To confirm if the alert is stale, check the date it was triggered—older timestamps usually indicate outdated alerts.
  • These can be resolved by following steps mentioned in the resolution section.