After adding an additional host to vCenter the newly added host is not able to see the vVol datastore that is present on the other hosts in the cluster.
The 1MB Protocol Endpoint (PE) LUN is visible at the SCSI layer (Standard Storage Devices).
Network connectivity to the VASA provider (typically port 8084) may show verified and stable.
The VASA provider status in vCenter may show "Online" with valid certificates.
The command esxcli storage vvol protocolendpoint list may not generate any output when run against the new hosts.
The command esxcli storage vvol storagecontainer list may not generate any output when run against the new hosts.
VMware ESXI (all versions)
The vVols datastore will not be automatic mounted on the new host for use and will need to be mounted via the “Mount Datastore to Additional Hosts” Procedure.
Mount the vVols datastore to the host/hosts that require access.
If you have unmounted a vVols datastore from all hosts, the datastore disappears from the inventory. To mount the vVols datastore that has been removed from the inventory, use the New Datastore wizard.
Create a Virtual Volumes Datastore in vSphere Environment
If you are having issues with the mount process please review the following kbs.
ESXi 7.X and later host newly added to vCenter is unable to access vVOl datastore
Mounting vVOL datastore on new ESXi hosts fails with "General System Error"
To speak with a customer representative or a Support Engineer see Contact Support. Scroll to the bottom of the page and click on your respective region.