ICDx Stored Procedure Stopped working after upgrading to a newer version of CCS
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ICDx Stored Procedure Stopped working after upgrading to a newer version of CCS

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Article ID: 395310

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite Control Compliance Suite Standards Module Control Compliance Suite Standards Database

Issue/Introduction

Control Compliance Suite (CCS)

Even though ICDx is End of Life, you are still using the stored procedure with CCS in your ICDx environment.  

After upgrading CCS to a newer CCS version (i.e. CCS 12.6.1 to CCS 12.7), the stored procedure fails with the following error:  

Msg 8115, Level 16, State 2, Procedure spGenerateCCSEventDataForICDx, Line 466 [Batch Start Line 2]

Arithmetic overflow error converting expression to data type int.

The statement has been terminated.

Environment

CCS 12.6.x

CCS 12.7

Cause

The problem is with seq_num column, and the value is going beyond the range of INT and is reporting the error.

Resolution

CCS Development has created a SQL script that run on CSM_Reports database.  Please contact CCS Support for the SQL script that resolves this issue.

It is recommended to back up your CCS databases before making any changes.

The script will change the data type for seq_num column from INT to BIGINT, as well as any other changes that are required.
After the script makes the necessary changes, the cluster index on this column will have to be re-created so the script may take some time to complete if you have a large number of records in the table.

Once this script completes successfully, run the ICDX stored procedure again and the error will be resolved.