Exceptions are no longer being applied in CCS
search cancel

Exceptions are no longer being applied in CCS

book

Article ID: 395304

calendar_today

Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite Control Compliance Suite Directory Services Control Compliance Suite Standards Database Control Compliance Suite Standards Module Control Compliance Suite Standards Middleware Control Compliance Suite Standards Network Devices

Issue/Introduction

Several exceptions in place that for some reason are no longer being applied to certain checks.  For example, there is one for All SQL Servers registered for NTFS Partitions not in use to exempt this check, but it is not being applied to any SQL Server for some reason.  It was working fine up until a couple of weeks ago and now it is not.

Environment

All supported versions of CCS.

Cause

Either the exception has expired and is no longer in the approved stage, or the assets are not included in the "Selected Assets" portion of the exception

Resolution

  • First verify that the exception is still valid and has not expired. State should be "Approved".

  • Next verify the "Associations" are correct. The Standard is in the correct path and the correct check(s) is selected, and the correct assets have been selected in the "Selected Assets".
    If using an asset folder or asset group, you will need to verify that the asset is in the correct folder/group.

 

  • If unsure if the asset is associated with the exception, find the specific asset(s) and look at their details, the "Exceptions" detail will show which if any exceptions apply to that asset.
    If the exception does not show up, either have the original "Requestor" update the exception to include the specific asset(s) or create a new exception for the specific asset(s) and standard/checks.