Unable to view Aria Operations plug in vCenter UI.
search cancel

Unable to view Aria Operations plug in vCenter UI.

book

Article ID: 395267

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

vCenter's Aria OPs plugin was not registered during a creation of VCF account, at the time of initial deployment.

Confirmed in vCenter's mob page, plugin is not registered under extensionmanager.

No traces of logs available in vCenter for any failure event for Aria Ops plug in.

Environment

vCenter 8.0 U3
Aria Ops 8.18.x

Cause

In 8.18 the registration button was removed from UI

Resolution

Perform below steps to register the plugin on VC

1. From Aria Ops UI find the resource UUID of the VC adapter instance resource.

2. Open the Ops swagger UI, select Internal APIs from dropdown - https://OPS_URL/suite-api/doc/swagger-ui.html?urls.primaryName=Internal%20APIs

3. Authorize using Ops credentials

4. Find register API - /internal/adapters/{adapterId}/vcenter/register

5. Click "Try it out" and provide required parameters
   * X-Ops-API-use-unsupported - true
   * adapterId - the UUID of the adapter instance resource which was determined from step 1
   * credentialParameters - SSO username and password of the VC
   
6. Click Execute - Expected response should be 200