404 NGINX Not Found Error When Logging in With SAML/SSO
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404 NGINX Not Found Error When Logging in With SAML/SSO

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Article ID: 395228

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Updated On:

Products

Carbon Black Cloud Endpoint Standard Carbon Black Cloud Enterprise EDR

Issue/Introduction

When logging in with Single Sign-On and Authenticating being redirected to a NGINX Not Found page with the error code 404

Environment

  • Carbon Black Cloud
  • SAML Provider

Cause

This happens when the ACS URL is wrong most likely because the Audience URI and ACS URL values are swapped

Resolution

  • The Broadcom AuthHub ASC URL is the same for everyone https://access.broadcom.com/default/saml/v1/sp/acs 
  • The Broadcom AuthHub Audience URI will look like https://access.broadcom.com/default/idp/UniqueValue but will be unique for each config
  • Update these values in the SAML or SSO config where these values are put may vary depending on the provider 

Additional Information