vSAN Witness host is in a non-responding state in vCenter after a reboot
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vSAN Witness host is in a non-responding state in vCenter after a reboot

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Article ID: 395194

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • In vCenter UI inventory, the vSAN Witness node is in a "non-responding" state.
  • A reboot may have been performed before the issue is seen.
  • Backups or snapshots of the vSAN Witness Application were taken at some stage before the issue was seen.

Environment

VMware vSAN (All versions).

Cause

Backups, restores, clones and snapshots of a vSAN Witness Host are not supported.

Resolution

Option 1:

  1. Navigate to the vSAN cluster.
  2. Click the Configure tab.
  3. Under vSAN, click Fault Domains.
  4. Un-stretch the vSAN Cluster by clicking on "disable the stretched configuration". - This will remove the witness host, but will leave the fault domains intact.
  5. Delete the Witness Disk Group.
    • In the same "Configure" tab, click on "Disk Management". In the Disk Group window, locate the witness host and select its disk group. Click Delete. 
  6. Stretch the cluster again - while performing this task, you will create a new disk group for the witness.

 

Option 2:

If Option 1 doesn't help to bring the vSAN Witness node to a normal state on vCenter inventory, a new Witness Appliance will need to be deployed and added to the cluster, and the impacted Witness Appliance should be deleted.

For assistance on how to deploy a new vSAN Witness Appliance, please refer to Deploying a vSAN Witness Appliance.

 

 

Furthermore, refrain from performing backups and from taking snapshots of a vSAN Witness Appliance in the future.

Additional Information