VMware Aria Automation で停止したイメージ同期を再開する
search cancel

VMware Aria Automation で停止したイメージ同期を再開する

book

Article ID: 395116

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

免責事項: これは英文の記事 Restarting stuck image synchronization in VMware Aria Automation の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

イメージ同期を強制的に再起動する方法

事象:

  • イメージ同期が 40分以上停止している
  • vCenter Server に問題がない

Environment

VMware Aria Automation 8.x

Cause

ストレージの停止や vCenter の異常によってこの問題が発生する可能性があります。

Resolution

VMware はこの問題を認識しています。詳細については、以下の回避策をご覧ください。

回避策:

  1. vCenter が正常であることを確認します。プロビジョニングしようとしている同じテンプレートから仮想マシンのクローンを作成します。
    1. この操作が失敗したりエラーが生成されたりした場合は、vCenter でこの問題を解決してから手順 2 に進みます。
  2. VMware Aria Automation 8.x (オンプレミス) を使用している場合は、プロビジョニング サービス ポッドを再起動します。
    kubectl delete pod -n prelude provisioning-service-pod-name
  3. サービスを再起動しても問題が軽減されない場合は、次の API を使用してイメージの同期をFAILEDとしてマークすると、VMware Aria Automation によって新しいイメージの同期が再試行されます。
curl --location --request PATCH 'https:// <FQDN> /iaas/api/cloud-accounts/ <cloud_account_id> ?apiVersion=2021-07-15' \ 
--header 'Authorization: Bearer <access_token> ' \ 
--header 'Content-Type: application/json' \ 
--data-raw '{ 
  "customProperties": { 
    "imageEnumerationTaskState": "FAILED" 
  }, 
  "privateKey":" <username_password> ", 
  "privateKeyId":" <username> " 
}'
注記
  • <FQDN> : オンプレミス VMware Aria Automation の FQDN です。
  • <access_token> : 次の手順で生成されます。
  • <cloud_account_id>,<username> : ブラウザから取得できます。それ以外の場合は、API GET /iaas/api/cloud-accounts を実行して取得できます。

Additional Information

影響/リスク:
オンプレミスの場合、プロビジョニング サービスを再起動すると進行中の展開はすべて失敗します。