The backup software is encountering an error "Could not fetch snapshot disk data" while attempting a snapshot-based backup of the VM.
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The backup software is encountering an error "Could not fetch snapshot disk data" while attempting a snapshot-based backup of the VM.

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Article ID: 395085

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

A virtual machine backup has failed with the error "Internal error XXX######## (Vmware.UnableFetchDiskData)". Incident  [UUID].

Symptoms:
1. The virtual machine snapshot task has already completed successfully.
2. The backup task on the vCenter GUI shows as successful.

However, the following errors are observed in the backup software: 

Could not fetch snapshot disk data. Error message: OpenVMDKResponse: handle=312, err=14009, transport_mode=, err_str=The server refused connection(err=14009)



Environment

VMware vCenter Server 7.x
VMware vCenter Server 8.x

Cause

The error occurs after the VMware snapshot task completes successfully, suggesting that the issue arises when copying the VMDK data to the backup software.
The backup software logs indicate a communication issue between the backup software and the ESXi host. This issue might occur if SSL is disabled or set to "false" on the ESXi host, preventing secure NBDSSL communication between the ESXi Host (902) and Backup Software.

Resolution

Resolution steps:

  1. Log into the ESXi server.
  2. Navigate to the ESXi server settings:
    Configuration → Advanced settings → Configuration → Defaults security
  3. Enable the following option: config.defaults.security.host.ruissl -> true