System error on Object List page in Classic Clarity
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System error on Object List page in Classic Clarity

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Article ID: 395073

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Updated On: 05-01-2025

Products

Clarity PPM SaaS

Issue/Introduction

After object XOG migration import, on custom object list in Classic there is a system error and the below error in logs:

ERROR 2025-04-02 09:58:58,029 [http-nio-8080-exec-138] niku.xql2 (clarity:xxxxxx:9561033__00452073-9F5C-4B83-8C30-BB2A4E8C8991:odf.sap_centerList) (e324a79c-fdc2-47ac-a0fb-37259d58264e) Internal Processing exception com.niku.odf.griphendor.GriphendorException: com.niku.union.persistence.PersistenceException: SQL error code: 0 Error message: ERROR: column "name" does not exist

Cause

Clarity attributes are not active due to corruption or incorrect update

Resolution

  • Check that all attributes for this object are active in odf_custom_attributes table
  • If not active, you may have to reimport the object instance and ensure the attributes are coming up