Aria Automation Orchestrator workflow fails with the LDAPException and resultCode 91
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Aria Automation Orchestrator workflow fails with the LDAPException and resultCode 91
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Article ID: 395023
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Updated On: 04-22-2025
Products
VMware Aria Suite
Issue/Introduction
Symptoms:
Aria Automation Orchestrator workflow that uses AD plugin, fails with the below LDAPException in the workflow run log : LDAP Server returned error:An error occurred while attempting to connect to server <Active Directory Domain>:636: IOException(LDAPException(resultCode=91 (connect error), errorMessage='Unable to establish a connection to server <Active Directory Domain>/<IP>:636 within the configured timeout of 20 milliseconds.', ldapSDKVersion=4.0.14, revision=<UUID>))
The domain has multiple domain controllers.
Environment
Aria Automation Orchestrator 8.x
Cause
The LDAPExceptionwith resultCode 91 indicates that the LDAP client in the Orchestrator was unable to connect to the directory server. This could be due various reasons :
The domain controller, the Aria Automation Orchestrator is trying to connect might be temporarily unavailable.
The domain controller resolved by the DNS server is demoted or unavailable in the environment.
The Aria Automation Orchestrator is timing out while waiting for the response from the Active Directory server.
Resolution
To resolve the issue correct the underlying network issue that's resulting in the network timeout when Aria Automation Orchestrator tries to connect with Active Directory domain controller.
To workaround the issue :
We can increase the maximum time to wait for the connection establishment from the default 20 milliseconds to a higher value by running Update an Active Directory serverworkflow from Aria Automation Orchestrator and update the timeout from the Advanced tab. Refer documentation Configuring the Active Directory Plug-In