The deployment of HCX Service Mesh fails with error: "Failed to run SOAP request Fetch The object"
search cancel

The deployment of HCX Service Mesh fails with error: "Failed to run SOAP request Fetch The object"

book

Article ID: 394982

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • When you are performing a Service Mesh deployment, you may see the following error in "Interconnect > More > Tasks":
  • On the log file /common/logs/admin/app.log you may find the following:
    2025-04-16 10:53:06.504 UTC [InterconnectService_SvcThread-19280, IX:######-####-####-####-##########, J:######xx, , TxId: ######-####-####-####-##########] INFO  c.v.h.i.u.InterconnectUnderlayUplinkUtil- Underlay test result for the appliance : {Fleet-Appliance-Name} Url : https://###.###.###.###:9443/uc/ondemand/results_pmtu?taskId=######### responseBody : {"taskId":"#########-1","startMeasureTime":1744800786,"endMeasureTime":0,"overallStatus":2,"tests":[{"localAddress":"###.###.###.###","remoteAddress":"###.###.###.###","currentLocalMtu":0,"currentRemoteMtu":0,"txPmtu":0,"rxPmtu":0,"status":2,"error":""}]}
    2025-04-16 10:53:23.627 UTC [TopologyService_SvcThread-32192, Ent: HybridityAdmin, , TxId: ######-####-####-####-##########] WARN  c.v.v.h.v.GenericVsphereInFrequentPoller- Failed to update the HwVersionConfigOptions inventory for the cluster compute resource {"value":"domain-####","type":"ClusterComputeResource"}com.vmware.vchs.hybridity.adapters.vsphere.vim.SOAPFaultException: Failed to run SOAP request Fetch The object 'vim.ClusterComputeResource:domain-####' has already been deleted or has not been completely created
    ...

Cause

The object described in the logs does not exist in the vCenter anymore, and the Compute Profile / Service mesh has not been properly updated or synced.

Resolution

Please review the vCenter environment to ensure that objects such as Datacenters, Clusters, ESXi hosts, and Datastores are properly synced with the Compute Profile. If any changes or deletions have occurred, make sure to update the Compute Profile and Service Mesh accordingly.

Update Compute Profile:

  1. Access the HCX UI
  2. Go to Interconnect > Compute Profiles tab
  3. Select the affected Compute Profile by name
  4. Click on Edit
  5. Go to the tab "Select Clusters", and make sure that the selected cluster and datastore exist in the vCenter.
  6. Click on continue until it finishes.

Resync:

  1. Access the HCX UI
  2. Go to Interconnect > Service Mesh tab
  3. Find the affected Service Mesh by name
  4. Click on Resync

Additional Information