vSphere cluster services health is not showing the health status. Shows "History is not available at the moment.".
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vSphere cluster services health is not showing the health status. Shows "History is not available at the moment.".

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Article ID: 394952

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

After the VCSA upgrade from 7.0 to 8.0 U2, vSphere client on “Monitor > vSphere Cluster Services > Health” page for cluster showing in the main section mostly blank with only broken image icon and note “History is not available at the moment. Learn More [link]”. (image below)

 

  • The  vCLS on a vSphere cluster are showing powered on and Running fine.
  • Confirm Cluster Health status.

    From VCSA MOB:

    • Go to the following url:

      https://<vcenter-fqdn>/mob/?moid=<cluster-id>&doPath=summary

    • Locate the "vcsHealthStatus" field in the summary table. The value should be "healthy".
    • If it is something other than healthy (such as degraded or nonhealthy), there is a problem with vCLS VMs in the given cluster.

    From the PowerCLI


    > Get-Cluster | select Name, @{N="VcsHealthStatus";E={$PSItem.ExtensionData.SummaryEx.VcsHealthStatus}}

Cause

vCLS health change happened at very early stage of vpxd initialization, and at that point the event system was not properly initialized. The vCLS healthy event was missed.

Resolution

Enable vCLS retreat mode following the steps in the below linked article.

  • Disable vCLS on a Cluster via Retreat Mode
  • Confirm all tasks for the cluster vCLS VMs have completed (e.g., power off, delete, etc.), then disable retreat mode.
  • Setting cluster back to "System Managed" allows the redeployment of new vCLS VMs, and republish of the health events (status).