wrong status returned from "systemctl status nimbus" - service inactive, data_engine core dump
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wrong status returned from "systemctl status nimbus" - service inactive, data_engine core dump

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Article ID: 394880

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When running "systemctl status nimbus" the status is returned as inactive (dead) and a core dump/stack trace for the data_engine is displayed.

The service appears to be running, all probes are green in Infrastructure Manager, alarms and data are flowing, but the status is incorrectly showing that the robot is stopped.

Additionally, the data_engine stack trace shows references to Oracle 12, but we are running Oracle 19.

 

Active: inactive (dead)

Process ##### (data_engine) of user 0 dumped core.

 

Environment

DX UIM 23.4.3
RedHat 9
Oracle 19 database

Cause

Incorrect Oracle instant client version

Resolution

To resolve this issue, you must upgrade the Oracle Instant Client on the primary hub from 12.x to 19.x and reconfigure the robot to point to the correct client version using this KB.

 

After upgrading the client, run the following commands on the primary hub to refresh the cached service status:

journalctl --rotate
journalctl --vaccum-time=1s
systemctl start nimbus

After this the correct service status will be displayed.