Error "Read timed out" while trying to create a new Virtual Machine in VMware Cloud Director.
search cancel

Error "Read timed out" while trying to create a new Virtual Machine in VMware Cloud Director.

book

Article ID: 394869

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Attempting to create a new virtual machine in VMware Cloud Director UI fails with below error:

com.vmware.ssdc.util.LMException: https://<vcenter.example.com>/sdk/vimService invocation failed with "java.net.SocketTimeoutException: Read timed out" at com.vmware.ssdc.util.LMException.wrap(LMException.java:135)

  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log you can see error as below:

    com.vmware.ssdc.util.LMException: https://<vcenter.example.com>/sdk/vimService invocation failed with "java.net.SocketTimeoutException: Read timed out"
            at com.vmware.ssdc.util.LMException.wrap(LMException.java:135)
            at com.vmware.ssdc.library.ExceptionFactory.createFromMultiple(ExceptionFactory.java:32)
            at com.vmware.vcloud.vdc.impl.ComposeRecomposeVAppActivity$FinalizeRecomposePhase.invoke(ComposeRecomposeVAppActivity.java:1565)
            at com.vmware.vcloud.activity.executors.ActivityRunner.runPhase(ActivityRunner.java:175)
            at com.vmware.vcloud.activity.executors.ActivityRunner.run(ActivityRunner.java:112)
            at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
            at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
            at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
            at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
            at java.base/java.lang.Thread.run(Thread.java:829)
    Caused by: com.vmware.vim.vmomi.client.exception.ConnectionException: https://<vcenter.example.com>/sdk/vimService invocation failed with "java.net.SocketTimeoutException: Read timed out"

Environment

VMware Cloud Director

Cause

This issue occurs when VMware Cloud Director loses connectivity to the vCenter server.

Resolution

After resolving the underlying network connectivity issues between vCenter and VMware Cloud Director, perform the following validations:

  1. Ping the vCenter from each VCD cell to confirm network connectivity is intact.

  2. Ensure port 443 is open between the VCD cells and vCenter using the command:

    curl -v telnet://<vCenter-IP>:443

Once connectivity is confirmed, proceed with the following steps to re-establish connection to vCenter:

  1. Reconnect vCenter server instance from VCD by following the document: Reconnect a vCenter Instance to Your VMware Cloud Director
  2. Refresh policy from VCD by following the document: Refresh the Storage Policies of a vCenter Instance in Your VMware Cloud Director