Error download plug-in. URL is unreachable. Connection reset error while downloading DELL omevv plugin in vCenter
search cancel

Error download plug-in. URL is unreachable. Connection reset error while downloading DELL omevv plugin in vCenter

book

Article ID: 394864

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Unable to download the DELL omevv plugin in vcenter after vCenter patching/upgrade.

Environment

vCenter 7.X

vCenter 8.X

Cause

Firewall blocking the connectivity of vCenter and DELL OpenManage Integration. 

For omevv plugin download it requires port 443 access from vCenter.

Port requirements:

Dell EMC OpenManage Version Port Information Guide Version 9.4 | Dell India

/var/log/vmware/vsphere-ui/vsphere_client_virgo.log:

DOWNLOAD_FAILED: Error downloading plugin package com.dell.plugin.OpenManage_Integration_for_VMware_vCenter_WebClient:1.4.0.1892 from https://XXX.XX.XX.XX:443/omevv/VcenterService/plugin.zip. Reason: URL is unreachable. Make sure that the URL is reachable.


[2025-03-24T07:27:34.758Z] [ERROR] sdk-plugin-deployer-167858    com.vmware.vise.plugin.extension.VcExtensionManager               Downloading plugin package: 'com.dell.plugin.OpenManage_Integration_for_VMware_vCenter_WebClient:1.4.0.1892' registered in vCenter: 'XXX-XXX-XXX(UUID_XXXXXXXXXXXXXXXX)' has failed. java.util.concurrent.CompletionException: com.vmware.vise.plugin.download.PluginDownloadException: java.net.SocketException: Connection reset

Resolution

1. If proxy is used in vcenter, please check the connectivity using wget command:

wget --no-check-certificate https://<vcenter_IP>:443/omevv/VcenterService/plugin.zip

2. Try to remove the omevv plugin from vcenter using MOB page and try registering using DELL open manage integration.

3. Check the firewall rules between proxy server/vcenter and DELL open manage and verify all ports are open as per above mentioned document.

4. Some version of omevv plugin like 1.4.X doesn't support TLS 1.3 in Open manage integration. Check TLS is configured to use 1.2 or earlier in Open manage side.

Check Dell documentation on version of plugin you are using for more information and to know issues with it.

Additional Information