System health shows the Cloud Service Status as Offline in dashboard of the VMware Cloud Director Availability Portal
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System health shows the Cloud Service Status as Offline in dashboard of the VMware Cloud Director Availability Portal

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Article ID: 394776

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Updated On:

Products

VMware Cloud Director VMware Cloud Director Availability - Disaster Recovery 4.x

Issue/Introduction

  • The System health panel on Dashboard of the VMware Cloud Director Availability (VCDA) Portal shows the Cloud Service in an offline state:

Cloud Service
Tunnel is activated
Status: Offline

  • In the Replication panels, you see messages similar to:

Connection refused. Check for down services (Manager, Replicator, Tunnel, etc)

  • On the Cloud Director Replication Management Appliance, you see the h4manager service constantly try to start but fails with journal messages like:

Apr 09 12:27:56 #### h4manager[5711]: 2025-04-09 12:27:56.966 ERROR 5711 --- [           main] o.s.boot.SpringApplication               : Application run failed
Apr 09 12:27:56 #### h4manager[5711]: org.springframework.context.ApplicationContextException: Unable to start web server; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tomcatConfigur>
...
Apr 09 12:27:56 #### h4manager[5711]: Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tomcatConfigurer': Injection of autowired dependencies failed; nested exception is java.lang.IllegalArgument>
...
Apr 09 12:27:56 #### h4manager[5711]: Caused by: java.lang.IllegalArgumentException: Could not resolve placeholder 'keystore.location' in value "${keystore.location}"

Environment

VMware Cloud Director Availability 4.7.3.1

Cause

This issue occurs when the /opt/vmware/h4/manager/config/application.properties file for the Manager Service is missing or corrupted.

Resolution

To resolve this issue, restore the /opt/vmware/h4/manager/config/application.properties file from a backup of the Manager Service.

If you don't have a backup to restore from, contact Broadcom Support and note this Article ID (394776) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information

For more information on backups in VMware Cloud Director Availability, see Back up all the appliances in the cloud and Restore the appliances in the cloud.