LB Activation from VCD fails with the error: "Record Not Found"
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Article ID: 394753
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Updated On:
Products
VMware Avi Load BalancerVMware Cloud Director
Issue/Introduction
In a VMware Cloud Director (VCD) environment, attempting to activate a load balancer for a T1 gateway backed by VMware Avi Load Balancer results in the error message: "Record Not Found.
This occurs when navigating through the Tenant UI in VCD, under the following path: Tenant UI > Org VDC > Networking > Edges > Edge Gateway > Load Balancer > General Settings > Edit, and toggling the "Active" switch.
Environment
VMware Avi Load Balancer
VMware Cloud Director
Cause
The failure occurs because VCD attempts to Modify the Tier 1 (T1) gateway with a new segment mapping within the NSX-T cloud, but this operation is dependent on modifying the cloud configuration on the Avi Load Balancer
The modification process fails due to the presence of a stale Service Engine (SE) group template attached under the NSX-T cloud configuration in Avi.
The stale SE group can be identified through the Avi controller's CLI(Bash Mode). Specifically, the octavius.ERROR log file located at /var/lib/avi/log/octavius.ERROR provides details about this failure
Resolution
To resolve the issue and successfully activate the load balancer, follow these steps:
Access the Avi controller via CLI.
In shell mode, run the following commands to remove the stale SE group template from the cloud configuration:
configure cloud <cloud_name>
no se_group_template_ref
save
After removing the stale SE group template, save the changes and exit.
Return to VCD and try activating the load balancer again.