Backup or restore can time out
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Backup or restore can time out

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Article ID: 394736

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Updated On:

Products

VCF Automation VMware Cloud Foundation

Issue/Introduction

In some rare cases, backup or restore operation can time out.

Environment

  • VMware Cloud Foundation 9.0
  • VCF Automation 9.0
  • VMware Identity Broker 9.0

Cause

We use default timeouts for backup and restore operation to ensure they can fail eventually if an operation is stuck for any reason. While these timeouts are large enough to handle majority of scenarios, in some rare scenarios backup or restore can take longer, leading to a workflow failure.

Resolution

If this occurs, please increase the timeout for the respective operation using LCM APIs. Default timeouts are 120 minutes for backup and 240 minutes for restore.

Method: POST

URL: https://<LCM hostname>/lcm/lcops/api/environments/<environment ID>/products/<product ID>/actions/invoke

Payload for backup timeout (affects both scheduled and on-demand backups):

{
  "name": "configure-packages",
  "properties": {
     "namespace": "vmsp-platform",
     "name": "vmsp-platform",
     "values": {"webhooks":{"hooks":{"backup":{"timeoutMins":"<timeout value in minutes>"}}}}
  },
  "ref": "/webhooks/core/vmsp/configure"
}

If you need to increase this timeout, please also set the timeout for incremental backups to 60 minutes using this payload:

{
  "name": "configure-packages",
  "properties": {
     "namespace": "vmsp-platform",
     "name": "vmsp-platform",
   "values": {"backups":{"incremental":{"timeouts":"60m"}}}
  },
  "ref": "/webhooks/core/vmsp/configure"
}

Payload for restore timeout:

{
  "name": "configure-packages",
  "properties": {
     "namespace": "vmsp-platform",
     "name": "vmsp-platform",
     "values": {"webhooks":{"hooks":{"restore":{"timeoutMins":"<timeout value in minutes>"}}}}
  },
  "ref": "/webhooks/core/vmsp/configure"
}