Cloud Proxy shows as Offline in the Aria Operations UI due to a failed patching attempt
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Cloud Proxy shows as Offline in the Aria Operations UI due to a failed patching attempt

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Article ID: 394726

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • You may receive an alert 'One or more vRealize Operations services on a cloud proxy are down'.
  • All cloud proxies are showing as offline in the Product UI.
  • The /var/log/haproxy-admin.log on the Cloud Proxy may show errors similar to:

    Server PrxyRC_BE/VROPS_0 is DOWN, reason: Layer6 invalid response, info: "SSL handshake failure", check duration: 161ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.

  • The following command entered via SSH on the cloud proxy identifies the certificate has expired.

openssl s_client -connect aria_operations_fqdn:443 

Environment

VMware Aria Operations 8.x

Cause

This issue can occur if the certificate for Aria Operations has expired.

Resolution

Complete either step 1 or step 2 before completing step 3.
  1. If you are using a custom certificate then generate a new certificate and follow Configure a Certificate For Use With VCF Operations 
  2. You can Reload the default certificate in Aria Operations.
  3. Once one of the above options has been completed, reboot all the cloud proxy appliances and they will be return to a connected state after sometime.