ESXi patching is failing with VMtools light error
search cancel

ESXi patching is failing with VMtools light error

book

Article ID: 394724

calendar_today

Updated On:

Products

VMware vSphere ESXi 7.0

Issue/Introduction

  • ESXi Patching Fails During Staging with VMTools light Error

  • On the ESXi host: /var/run/log/esxupdate.log

<timestamp>:25Z esxupdate: 2130439: root: ERROR: Traceback (most recent call last):

<timestamp>:25Z esxupdate: 2130439: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 772, in <module>

<timestamp>:25Z esxupdate: 2130439: root: ERROR:     main()

<timestamp>:25Z esxupdate: 2130439: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 763, in main

<timestamp>:25Z esxupdate: 2130439: root: ERROR:     ret = CMDTABLE[command](options)

<timestamp>:25Z esxupdate: 2130439: root: ERROR:   File "/usr/lib/vmware/esxcli-software", line 631, in ComponentSigVerifyCmd

<timestamp>:25Z esxupdate: 2130439: root: ERROR:     res = h.GetCompSigVerifyMap(opts.rebooting)

<timestamp>:25Z esxupdate: 2130439: root: ERROR:   File "/lib64/python3.8/site-packages/vmware/esximage/HostImage.py", line 1328, in GetCompSigVerifyMap

<timestamp>:25Z esxupdate: 2130439: root: ERROR:     vibInfo = vibResult[vibId]

<timestamp>:25Z esxupdate: 2130439: root: ERROR: KeyError: 'VMware_locker_tools-light_12.4.0.23259341-23259329'

Environment

VMware vSphere ESXi 7.x

Cause

On the ESXi host /locker/packages/var/db/locker/vibs failed to reflect updates from the new tools-light package.

Resolution

  • Login to the ESXI host via SSH.

  • Navigate to the following directory on the host:/locker/packages/var/db/locker/vibs.

  • Identify the current VMTools version files in /locker/packages/var/db/locker/vibs and create a test file in the same directory to ensure there is no file corruption.

  • If no corruption is found, move the existing VMtools files to a temporary backup folder. This is to ensure the files do not interfere with the patching process.

  • If another host in the environment has been successfully patched and is working fine, copy its VMtools files from the /locker/packages/var/db/locker/vibs directory to the non-working host’s corresponding directory.

  • After copying the files, reattempt the patching process on the non-working host.

Note: In case of patch failure post these steps , follow the below steps to resolve the issue:

  • Run the following command to check the available VMtools version:

    esxcli software vib list | grep tools

  • Uninstall the Current VMtools VIB : 

esxcli software vib remove --vibname=<name_of_vib>

  • Log in to the Broadcom portal (formerly VMware) and download the offline bundle of the required VMtools version. 

  • Using the vSphere client, create a baseline using the offline bundle for the desired VMtools version.Attach the newly created baseline to the host. 

  • Initiate remediation to push the updated VMtools version to the host.

  • After remediation, verify that the new VMtools version has been successfully installed and is functioning as expected.