Container volume health status displays as "Unknown" in the web UI after an ESXi host upgrade
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Container volume health status displays as "Unknown" in the web UI after an ESXi host upgrade

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Article ID: 394712

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Updated On:

Products

VMware vSAN VMware vCenter Server

Issue/Introduction

  • Following an upgrade of ESXi hosts in a vSAN-based environment, container volumes are displaying a health status of "Unknown" in the web UI. This issue specifically affects volumes backed by a vSAN datastore that were created prior to the upgrade.
  • Existing container volumes: Health status shows as Unknown.
  • Newly created container volumes: Health status shows as Healthy.
  • The vmware-sps service fetches compliance data for First Class Disks (FCDs) as recorded on the vCenter server. Logs can be reviewed at /var/log/vmware/sps/sps.log: 

YYYY-MM-DD [pool-4-thread-18] INFO  opId=563d288a-ea00-####-aeda-6e2052fe0b4c com.vmware.pbm.compliance.impl.ComplianceManagerImpl - Starting Timer: fetchOrCheckCompliance. Fetch: true. Entities: [ServerObjectRef{key = d1b203dc-bf45-####-952c-61f327c4f768}, ServerObjectRef{key = 5c1c9366-3d71-####-920d-9dcc80d2571d}, ServerObjectRef{key = 4b4a77ff-8df7-####-baa2-9663db7efb08}, ServerObjectRef{key = 02106a6e-cd15-####-935f-51cbadf2c8ea}]

  • Because no compliance data is returned, the Health API returns an error:

YYYY-MM-DD [pool-4-thread-18] WARN  opId=563d288a-ea00-####-aeda-6e2052fe0b4c com.vmware.vim.storage.common.vc.impl.VcQueryImpl - [getDatastoresForUrl] Given set of datastore URLs is null/empty
YYYY-MM-DD [pool-4-thread-18] DEBUG opId=563d288a-ea00-####-aeda-6e2052fe0b4c com.vmware.pbm.compliance.impl.ComplianceManagerImpl - Retuirning ComplianceResult : []

Cause

  • The issue is caused due to failure in retrieving the compliance data for the affected FCDs. During compliance checks, Storage Policy-Based Management (SPBM) service initiates a call to fetch compliance information. However, no data is returned for certain volumes, leading to an error in the health status display.
  • Such failures indicates that compliance check is failing to retrieve necessary policy information, which results in health API being unable to provide accurate status updates.
  • These errors are a result of missing or outdated policy association data following the ESXi upgrade.

Resolution

If observed symptoms match those described above, contact Broadcom Support for a resolution

Additional Information

Note: The vSAN Default Storage Policy is typically the Datastore Default policy for a vSAN datastore. In cases where the policy association is missing, the UI may display the policy as “Datastore Default,” which causes compliance checks to fail and the health status to appear as “Unknown.”