Container volume health status displays as "Unknown" in web UI after ESXi Host Upgrade
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Container volume health status displays as "Unknown" in web UI after ESXi Host Upgrade

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Article ID: 394712

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Updated On:

Products

VMware vSAN VMware vCenter Server 8.0

Issue/Introduction

  • Following an upgrade of ESXi hosts in a vSAN-based environment, container volumes are displaying a health status of "Unknown" in web UI. This issue specifically affects volumes backed by  vSAN datastore that were created prior to the upgrade.
    1. Existing container volumes show health status as Unknown.

    2. Newly created container volumes display a Healthy status.

  • First SPS fetches compliance data for FCDs:

2025-03-12T18:06:35.772+11:00 [pool-4-thread-18] INFO  opId=563d288a-ea00-473e-aeda-6e2052fe0b4c com.vmware.pbm.compliance.impl.ComplianceManagerImpl - Starting Timer: fetchOrCheckCompliance. Fetch: true. Entities: [ServerObjectRef{key = d1b203dc-bf45-48f4-952c-61f327c4f768}, ServerObjectRef{key = 5c1c9366-3d71-4551-920d-9dcc80d2571d}, ServerObjectRef{key = 4b4a77ff-8df7-441e-baa2-9663db7efb08}, ServerObjectRef{key = 02106a6e-cd15-4e06-935f-51cbadf2c8ea}]

  • No compliance data is returned, so health API returned error.

2025-03-12T18:06:35.780+11:00 [pool-4-thread-18] WARN  opId=563d288a-ea00-473e-aeda-6e2052fe0b4c com.vmware.vim.storage.common.vc.impl.VcQueryImpl - [getDatastoresForUrl] Given set of datastore URLs is null/empty
2025-03-12T18:06:35.783+11:00 [pool-4-thread-18] DEBUG opId=563d288a-ea00-473e-aeda-6e2052fe0b4c com.vmware.pbm.compliance.impl.ComplianceManagerImpl - Retuirning ComplianceResult : []

  • Check if all these FCDs are present in the CNS database and appear to be correct:

COPY cns.volume_info (volume_id, volume_name, volume_type, mark_for_delete, datastore, last_modified_date, static_provision, capacity, vclock, is_cns_volume, disk_path, backing_object_id, used_capacity, create_time, allocated_space) FROM stdin;

 

Environment

VMware vCenter Server 8.X

Cause

  • The issue is caused due to failure to retrieve compliance data for the affected FCDs. During compliance checks, Storage Policy-Based Management (SPBM) service initiates a call to fetch compliance information. However, no data is returned for certain volumes, leading to an error in the health status display.
  • This indicates that compliance check is failing to retrieve necessary policy information, which results in health API being unable to provide accurate status updates.
  • This issue is a result of missing or outdated policy association data after the ESXi upgrade.

Resolution

If the above symptoms match, please contact Broadcom Support for a resolution

Additional Information

Note: The vSAN Default policy is typically Datastore Default policy for a vSAN datastore. In cases where policy association is missing, the UI may display the policy as “Datastore Default,” causing compliance checks to fail and health status to appear as “Unknown.