Error at vSAN Skyline Health - Not enough free space for vSAN performance database object
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Error at vSAN Skyline Health - Not enough free space for vSAN performance database object

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Article ID: 394700

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Updated On: 05-09-2025

Products

VMware vSAN

Issue/Introduction

vSAN Stats DB object is running low on free space it can support

Environment

VMware vSAN 8.0.x

Cause

"Enable network diagnostic mode" option is checked.
The vSAN Stats DB object is running low on free logical disk space. The vSAN Stats DB object is limited to 512 GB. If the utilization reaches above 95 percent, it enters a Red error state. History data in the Stats DB object is kept for approximately three months (93 days), and old data is purged.

Resolution

Take the following steps to resolve the issue.

  • Uncheck "Enable network diagnostic mode"
  • Disable and re-enable "vSAN Performance service" following below steps.
In vCenter 8.0, to disable and re-enable vSAN Performance service, follow the below steps:
  1. Log into RVC via vCenter SSH.
    1. Open vCenter SSH.
    2. Log into shell
    3. Run the command: rvc
    4. Login with administrator@<domain>@localhost
  2. cd into localhost > datacenter > computers > vSAN Cluster
  3. Then run the command to delete the vSAN performance object: vsan.perf.stats_object_delete .
  4. Once deleted, proceed to create the vSAN performance object by using the command: vsan.perf.stats_object_create .
Note: 
  • You can also re-enable Performance Service via the vCenter Web Client.
  • Disabling/re-enabling Performance Service will wipe out any existing performance data.
  • "Enable network diagnostic mode" should only be used only during troubleshooting and should be unchecked after that. For more information refer to vSAN Health Service - Performance service - Network diagnostic mode