SCIM server does not work when click on the API icon after an Instance has been enabled
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SCIM server does not work when click on the API icon after an Instance has been enabled

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Article ID: 394537

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Updated On:

Products

CA Directory

Issue/Introduction

An attempt to configure the SCIM services by following the product documentation at the following link:

Configuring the SCIM Demo

after enabled the SCIM instance, administrators are asked to click on the API icon to start the Swagger UI. Instead of asking the credential, it showed the error message. "Resource SCIMServer not found."

Environment

Release: 14.1
Component: CA Directory

Cause

At the time the "CA Directory SCIM server' started, the "Management UI server" might not have the <hostname>-management-ui DSA ready for it to function correctly. As a result, the "CA Directory SCIM server" also failed to work properly.

Resolution

Since this issue occurred when an administrator was clicking on the API icon, it meant that the <hostname>-management-ui DSA had been started to allow the administrator to login to the Management UI.

Hence as a workaround, when the product documentation is followed between the steps:

Steps to enable the SCIM Instance

1. On the SCIM page, select the SCIM Instance.
2. Click the Enable button to make the instance available for testing.

and

Launch Swagger

For a Windows server, restart the "CA Directory SCIM server" service.

For a Linux server, use the dxscimserver command that is under the management-ui subdirectory to stop and start the  service.