Previously Working Process Suddenly Fails
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Previously Working Process Suddenly Fails

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Article ID: 394497

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

Customer reports that a previously working process is suddenly not working despite no relevant changes to the Process Automation Environment

The customers process references an external xls file and reads information from there.

Attempts to access this file result in errors like:

In Excel: "The file format and extension of '<FILE_NAME>.xls' don't match. The file or could be corrupted or unsafe. Unless you trust its source, don't open it. Do you want to open it anyway?"

Access Denied

File Exists

File Not Found 

In ITPAM 4.4.x, PAM\wildfly\standalone\log\c2o.log may contain logs similar to:

In ITPAM 4.3.x this file is located at PAM\server\c2o\log\c2o.log

2025-03-28 14:10:39,314 ERROR [com.ca.pam.server.OasisBaseRemoteServiceServlet] [<PROCESS_ID>] DOC_ALREADY_PURGED
com.optinuity.c2o.util.C2OException: DOC_ALREADY_PURGED
    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:67)
    at com.optinuity.c2o.util.ExceptionUtil.createException(ExceptionUtil.java:60)
    at com.optinuity.c2o.persistence.DatabaseManager.loadC2ODocument(DatabaseManager.java:5428)
 
and/or

2025-03-28 01:54:46,141 ERROR [com.optinuity.c2o.service.serviceoperation.filewatchserviceoperation.DirectoryEntriesFWSRunner] [<PROCESS_ID>] Failed to run DirectoryEntriesFWSoperation
java.lang.NullPointerException

Environment

All versions of Process Automation

Cause

Process Automation does not have permission to access these files.

Resolution

The errors reported indicate a permissions issue with the files PAM is trying to access.

Ensure that the user configured in the PAM process has the appropriate read, write, and execute permissions based on the purpose of the related process.