"Virtual Object" for a Managed disk appears as inaccessible in VC but does not exist in vSAN.
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"Virtual Object" for a Managed disk appears as inaccessible in VC but does not exist in vSAN.

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Article ID: 394469

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Updated On:

Products

VMware vSAN

Issue/Introduction

In vCenter, Skyline health shows a "Virtual Object" as "inaccessible". However the object does not appear to be in vSAN.

This is showing as a "Managed Disk" in Skyline Health.

 

 

Environment

To check if the object exists at vSAN level:

open ssh connection to any host in the vSAN cluster and run:

cmmds-tool find -u <Object UUID as shown in VC> -f json

This command returns no entries:

{
 "entries":
[
]
}

Cause

In rare cases, the vSphere inventory of managed virtual disks can become temporarily out of sync with datastore disk backing metadata.

Resolution

The steps located in this KB: https://knowledge.broadcom.com/external/article/321994/  show how to reconcile the datastore inventory.
The reconciliation operation applies to managed virtual disks, which are independent virtual storage objects that vSphere can create and maintain with or without attachment to a virtual machine.

 

Post reconciliation the inaccessible object will be gone from Skyline Health.