Site Recovery Plugin not visible on vSphere Client. Error seen on Site Recovery Page - "vSphere Replication: UI error: Unable to read configuration"
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Site Recovery Plugin not visible on vSphere Client. Error seen on Site Recovery Page - "vSphere Replication: UI error: Unable to read configuration"

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Article ID: 394405

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Site Recovery page when opened manually displays the following error for vSphere Replication:

"vSphere Replication: UI error: Unable to read configuration"

  • The Site Recovery Plugin is not visible on the vSphere Client.

  • When "Configure" is clicked for the vSphere Replication appliance, to open its VAMI page, it does not open and displays that the site cannot be reached. The appliance is configured with FQDN.

  • The VAMI page can be opened using IP address of the vSphere Replication appliance.

Environment

VMware vSphere Replication 8.x

Cause

  • The FQDN configured for the appliance is not resolving to the IP address. This suggests a DNS resolution issue for the FQDN.

  • Due to this the vCenter is unable to connect with the vSphere Replication appliance to retrieve any information and also the plugin details.

Resolution

To resolve this issue, fix the DNS resolution issue for the FQDN which is used for the vSphere Replication appliance.

To temporarily workaround the issue, the below can be performed:

  1. Open VAMI page of vSphere Replication appliance.
  2. Click on "Reconfigure".
  3. In the "Name & Extension" tab of the reconfigure wizard, for the "Local host" enter the IP of vSphere Replication appliance instead of the FQDN.
  4. Finish the reconfiguration.

Now the Site Recovery Plugin should be visible.

Once the FQDN's DNS resolution issue is fixed, perform the above steps once again and on step 3 enter the FQDN instead of the IP.