Hosts Pre-Check Errors for removed hosts
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Hosts Pre-Check Errors for removed hosts

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Article ID: 394401

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Updated On:

Products

VMware NSX

Issue/Introduction

While running an upgrade Pre-Check against Hosts, a number of errors are returned for hosts that are no longer managed by NSX.

Errors may include:

  • "Failed to execute Manager connectivity check."
  • "Unable to retrieve Firewall module status on ESXi host"
  • "Error while checking if host reboot is pending from a previous action."
  • "Failed to execute ESXi maintenance-mode upgrade dataplane check."
  • "Failed to execute ESXi supported versions check."
  • "Failed to execute Maintenance-mode check."
  • "Error while checking free space on ## partition on host"
  • "Failed to execute DRS status check."
  • "Failed to execute Maintenance-mode check."

The name and UUIDs of affected transport nodes can be found in the pre-check error messages.

You may be able to verify some of these errors by using the API and retrieving the transport node state. 
 
GET API '/api/v1/transport-nodes/{transport-node-uuid}/state' may show any of the following identifiers:
"node_deployment_state": {
"state": in_progress"
...
},
"deployment_progress_state": {
"current_step_title": "Removing host status"
...
},
"state": "orphaned",
...
"failure_message": "Host configuration failed.  Number of retries: ###.  Next retry attempt will be ..."
 
Searching for the {transport-node-uuid} may return a result, but following the transport node name hyperlink returns a filtered Hosts page with no results.
 
Example of following the hyperlink for the host:
 
 
 

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

The search index is out of sync.

Resolution

  1. On all NSX manager nodes, log in as the admin user and run the following two commands:

    start search resync policy

    start search resync manager

  2. After you run the above commands, please allow some time for the reindexing to complete.  The time will vary based on environment size.  Expect at least 10 minutes.  During the reindexing, the NSX UI may display an error that indicates to try again later.  This is normal and will reconcile when indexing is complete.
  3. Search for the affected hosts using their UUIDs and follow the hyperlink to the host details.  Select the checkbox next to the host then choose to "Remove NSX" with the "Force" checkbox.
  4. Re-run the Hosts Pre-Check to verify the errors have been cleared.