Compute Manager vCenter registration failed because of Unknown error in processing request for CM
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Compute Manager vCenter registration failed because of Unknown error in processing request for CM

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Article ID: 394395

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

After breaking multiple vCenter's Enhanced Link Mode (ELM), you will be unable to connect to the Compute Manager in NSX.

  • May be present after:
  • A password Change for CM connect
  • A user change for CM connect.
  • The CM thumbprint will be correct
  • A Reboot will not resolve the condition
  • Examples:

Environment

VMware NSX 4+
VMware NSX-T 3+

Cause

When a cross-domain repoint (changed the SSO domain) is performed, you can experience a known bug in the process.  

  • The domain-repoint script fails to update the vpxd.cfg file with the correct SSO domain name for the vpxd solution user.  
  • NSX relies on the vpxd solution user to register itself with vCenter using a token.  
  • Because the vpxd solution user no longer exists, a consequence of the old domain no longer existing, NSX cannot register itself.

Resolution

This is not an NSX issue, for resolution, please refer to the KB:

VPXD.CFG file is not updating solution user with the new SSO domain name