SSL handshake error occurs on connector server when attempting to delete many users via bulk loader client.

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Article ID: 39428

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Symptoms: 

The following SSL handshake error occurs on connector server when attempting to delete many users via bulk loader client.

   ”javax.net.ssl.SSLHandshakeException: SSL handshake failed.
   Caused by: javax.net.ssl.SSLHandshakeException: Invalid Padding length: 84
   Caused by: javax.crypto.BadPaddingException: Invalid Padding length: 84”

 

Environment:  

JCS JVM is JRE 1.7.76 or earlier.

 

Cause: 

Java 1.7.0_40 which was shipped with Out-Of-The-Box JCS has a problem.

 

Resolution:

To fix this problem, please upgrade Identity Manager to r12.6 SP4 CR4 which is upgraded to Java 1.7.80. Please contact CA Support to get the
r12.6 SP4 CR4.

If you are not able to upgrade Identity Manager soon, as a workaround, please upgrade JVM on Identity Manager to JRE 1.7.79 or 1.7.80 as shown below.

1. Download the latest JRE 1.7.79 or 1.7.80.

2. On JCS machine, at the command line $> net stop im_jcs

3. Go to <im_install>\ConnectorServer folder and rename “jvm” folder to “jvm.old”.

4. Copy the extracted JRE folder to <im_install>\ConnectorServer folder and rename as “jvm”.

5. $> net start im_jcs

Environment

Release: CAIDMB99000-12.6.4-Identity Manager-B to B
Component: