Unable to login to SRM due to Permission issue.
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Unable to login to SRM due to Permission issue.

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Article ID: 394275

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Users are unable to login to SRM and perform any activity respective to PG.
  • Insufficient privileges to perform the operation message may appear while trying to login to the SRM.

Environment

VMware Site Recovery Manager 8.x
VMware Live Site Recovery 9.x

Cause

  • This happens when user trying to login does not have sufficient permission to perform the SRM operations.

  • You may see below messages in /var/log/vmware/srm/vmware-dr.log on SRM appliance.


2025-03-19T08:47:58.367Z error vmware-dr[02459] [SRM@6876 sub=authorize opID=06c2327d-3e40-40cd-9f20-67ff474b92eb-loginByToken] [52ed6] AddConnection: User 'domain\username' does not havSystem.Read privilege on root
2025-03-19T08:47:58.367Z error vmware-dr [02459] [SRM@6876 sub=SessionManager opID=06c2327d-3e40-40cd-9f20-67ff474b92eb-loginByToken] [52ed6] Failed to login session '52ed6' - Insufficient pivileges for user 'domain\username':
-> (vim. fault.NoPermission) {
faultCause = (vmodl.MethodFault) null,
faultMessage = <unset>,
object = 'dr.ServiceInstance: 75ebe4cc-f573-4f30-8e0f-c3c857482698:DrServiceInstance',
privilegeId = "System.Read",
missingPrivileges = <unset>
msg = ""

Resolution

The issue can be fixed by enabling the user with required permissions. 

The below article has the instructions to enable the user permissions on SRM.

Assign Site Recovery Manager Roles and Permissions

Additional Information